echofon抛弃小众平台

echofon官方已经宣布暂时不支持一些小众平台,包括64位平台,FreeBSD,OpenSolaris等,很不幸,我使用的正是ubuntu 10.04 amd64版本,所以升级到echofon 1.9.6.6后,启动firefox会提示”Echofon does not support this platform or custom build Firefox. (Can’t get OAuth signer.) / Cc[‘@naan.net/twitterfox-sign;1’] is undefined (Fx version 3.6.9 / ABI x86_64-gcc3)”,杯具。1.9.6.4版本可以继续使用,echofon还是很不错的,为什么要抛弃用户呢?官方说正在做工作支持这些小众平台,谁知道猴年马月呢!

ff带套(tor)翻墙上youtube无法播放视频问题的解决办法

firefox 3.6带套上youtube(一定要代理*.youtube.com,只代理www.youtube.com是不可以的),首页页面显示混乱,打不开视频,随便点击一个视频连接,出现提示“Hello, you either have JavaScript turned off or an old version of Adobe’s Flash Player. Get the latest Flash player.” flash版本不够新云云。如果更新了adobe flash player并且打开了JavaScript还是无法观看,请将这个网址ytimg.com一并加入tor代理网络,应该就可以正常观看了。不是火狐的问题,也不是洋葱的问题,都是该死的Great Fucking Wall的问题。郁闷了很久…

ubuntu 9.10(kamic koala) amd64编译安装firefox 3.6(namoroka)

  代号为”namoroka”的firefox 3.6正式发布了,性能提升不少。ubuntu估计要到下一个版本10.04(Lucid Lynx)才会更新到firefox 3.6,但愿不要这么晚。mozilla官方不提供amd64版本的安装包,那么下载源代码本地编译吧,这样性能还能更优。编译安装步骤如下,参考了官方build文档
  
  0. 准备编译环境和依赖
  sudo apt-get build-dep firefox
  sudo apt-get install libasound2-dev libcurl4-openssl-dev libnotify-dev libxt-dev libiw-dev mesa-common-dev autoconf2.13
Continue reading “ubuntu 9.10(kamic koala) amd64编译安装firefox 3.6(namoroka)”

xmarks也被”和谐”掉

  大约从前天开始xmarks开始不正常,无法同步,总以为只是xmarks服务器在维护什么的,很快就能用了,毕竟用了这么久,都习惯了。好几天过去了,还是不能用,google一下,原来大家都无法同步,原来是被“墙”了,真不敢相信,这么个有用的工具,招谁惹谁了。现在连骂都不想骂了,真应了那句话,“天朝有风险,投胎需谨慎”。
  xmarks之后,下一个遭毒手的会是谁呢?

Ubuntu 9.04下安装Firefox 3.5正式版(Release)

让我们翘首企盼的firefox 3.5正式版(Release)于6月30日正式推出,但是Ubuntu社区却迟迟没有更新,至今已经有半月,官方源仍然毫无动静,难道是因为bug太多,要等到firefox 3.5.1再进行更新?不得而知了。

看来暂时只有自己动手,丰衣足食了。对于firefox的安装我不推荐使用非官方源,而是从Mozilla下载更新,3.5与以前的版本并存,这样当Ubuntu官方源更新的时候,可以顺利的更新到最新的官方firefox版本。

firefox 3.5的安装比较简单,从mozilla下载回来的文件名字为firefox-3.5.tar.bz2,遵循FHS(Filesystem Hierarchy Standard)的指导意见,firefox最好安装到/opt目录下面,用下面的命令直接把bz2包解压到/opt目录下就可以了。
tar jxvf firefox-3.5.tar.bz2 -C /opt
这样就算安装完成了,命令行运行/opt/firefox/firefox或者建一个桌面快捷方式都可以,记得一定要运行/opt/firefox目录下的firefox,而不是firefox-bin或run-mozilla.sh。
这样两个版本的firefox使用同一套profile,可以和平共处,至于暂时不兼容的插件(Extensions)hack一下吧。